Radius пишет Error: Discarding duplicate request from client

Установка, настройка, поддержка
Ответить
net_flyer
Сообщения: 9
Зарегистрирован: Пн мар 01, 2010 5:35 pm

Radius пишет Error: Discarding duplicate request from client

Сообщение net_flyer » Пт мар 05, 2010 1:33 pm

Пожелуйста хе-е-е-лп уже незнаю чо смотреть, связка abills+microtik 3.22
Соединение PPPoE проходит связ устанавливется, все вроде ок, только трафик подсчитывается дважды
test 2010-03-05 11:46:27 00:02:24 100 2.74 Kb 446 Bt 00:50:BA:50:6E:08 2 192.168.0.1 0.000000 (D) Удалить
test 2010-03-05 11:46:26 00:02:24 100 2.74 Kb 446 Bt 00:50:BA:50:6E:08 2 192.168.0.1 0.000000 (D) Удалить
test 2010-03-01 17:11:19 00:07:34 100 1.16 Kb 206 Bt 00:50:BA:50:6E:08 2 192.168.0.1 0.000000 (D) Удалить
test 2010-03-01 17:11:18 00:07:34 100 1.16 Kb 206 Bt 00:50:BA:50:6E:08 2 192.168.0.1 0.000000 (D) Удалить
test 2010-03-01 17:06:52 00:04:24 100 67.54 Kb 2.50 MB 00:50:BA:50:6E:08 2 192.168.0.1 0.000000 (D) Удалить
test 2010-03-01 17:06:51 00:04:24 100 67.54 Kb 2.50 MB 00:50:BA:50:6E:08 2 192.168.0.1 0.000000 (D) Удалить
test 2010-03-01 16:35:17 00:00:57 100 5.84 Kb 3.63 Kb 00:50:BA:50:6E:08 2 192.168.0.1 0.000000 (D) Удалить
test 2010-03-01 16:35:17 00:00:57 100 5.84 Kb 3.63 Kb 00:50:BA:50:6E:08 2 192.168.0.1 0.000000 (D)
Вот так примерно в отчете это выглядит,
В логах радиуса мелькает следующая ошибка
Fri Mar 5 16:07:55 2010 : Error: Discarding duplicate request from client user-network port 40741 - ID: 153 due to unfinished request 0
Fri Mar 5 16:07:56 2010 : Auth: Login OK: [test] (from client linet-network port 104 cli 00:50:BA:50:6E:08)
Fri Mar 5 16:07:56 2010 : Error: Discarding duplicate request from client user-network port 35923 - ID: 155 due to unfinished request 2
Fri Mar 5 16:07:56 2010 : Error: Discarding duplicate request from client user-network port 55036 - ID: 156 due to unfinished request 3

а при запуске radiusd -X при установлении соединения проскакивают ошипки
+- entering group preacct
++[preprocess] returns ok
Use of uninitialized value in length at /usr/abills/libexec/../Abills/mysql/Acct.pm line 70.
Use of uninitialized value in pattern match (m//) at /usr/abills/libexec/../Abills/mysql/Acct.pm line 74.
Use of uninitialized value in concatenation (.) or string at /usr/abills/libexec/../Abills/mysql/Acct.pm line 373.
Use of uninitialized value in concatenation (.) or string at /usr/abills/libexec/../Abills/mysql/Acct.pm line 373.
Use of uninitialized value in concatenation (.) or string at /usr/abills/libexec/racct.pl line 134.
Exec-Program output:
Exec-Program: returned: 0
++[abills_acc] returns ok
Finished request 1.
Буду рад любой подсказке :?:

net_flyer
Сообщения: 9
Зарегистрирован: Пн мар 01, 2010 5:35 pm

Re: Radius пишет Error: Discarding duplicate request from client

Сообщение net_flyer » Пт мар 26, 2010 8:37 am

ППц, :( неужели у меня одного только такая трабла, изменил значение таймаута в настройках радиуса на МТ ошибка Error: Discarding duplicate request from clientError: пропала, но в статистике попрежнему трафик считается дважды :(

NiTr0
Сообщения: 767
Зарегистрирован: Пт фев 08, 2008 4:46 pm

Re: Radius пишет Error: Discarding duplicate request from client

Сообщение NiTr0 » Пт мар 26, 2010 9:57 am

дважды модуль радиуса подгружен на насе.

net_flyer
Сообщения: 9
Зарегистрирован: Пн мар 01, 2010 5:35 pm

Re: Radius пишет Error: Discarding duplicate request from client

Сообщение net_flyer » Пт мар 26, 2010 10:53 am

В роли НАСа используется микротик, как на нем может быть загружен модуль радиуса дважды
да и еще при запуске radiusd -X видно, что на радиус приходит аж 3 старт пакета а потом 3 стоп пакета и в статистике трафик абонента будет сосчитан 3 раза, с чем ж это можетбыть связано

NiTr0
Сообщения: 767
Зарегистрирован: Пт фев 08, 2008 4:46 pm

Re: Radius пишет Error: Discarding duplicate request from client

Сообщение NiTr0 » Пт мар 26, 2010 11:13 am

net_flyer писал(а):В роли НАСа используется микротик, как на нем может быть загружен модуль радиуса дважды
Вам виднее, что с вашим насом творится...
net_flyer писал(а):да и еще при запуске radiusd -X видно, что на радиус приходит аж 3 старт пакета а потом 3 стоп пакета и в статистике трафик абонента будет сосчитан 3 раза, с чем ж это можетбыть связано
С насом. Он шлет 3 пакета подряд. Почему - сказать не могу, с микротиком не работал и работать навряд буду.

net_flyer
Сообщения: 9
Зарегистрирован: Пн мар 01, 2010 5:35 pm

Re: Radius пишет Error: Discarding duplicate request from client

Сообщение net_flyer » Пт мар 26, 2010 1:00 pm

Спасибо за наводку, буду копать микротик!

yuracher
Сообщения: 63
Зарегистрирован: Вт авг 11, 2009 6:56 am
Откуда: Коломия
Контактная информация:

Re: Radius пишет Error: Discarding duplicate request from cl

Сообщение yuracher » Чт фев 03, 2011 9:21 am

Вже другий місяць підряд першого числа починаючи з 00:00 годин спостерігаються такі ж помилки. Система: FreeBSD 6.4-STABLE+freeradius-1.1.7_3(rlm_exec)+perl-5.8.9_2+mysql-server-5.0.77_1+apache-2.0.63_2+Cisco 2811 (PPPoE)+ABillS 0.52b.
Конфіги freeradius взято з каталогу /usr/abills/misc/freeradius/. Конфіг Cisco, який відповідає за PPPoE станом на 01.02.2011:

Код: Выделить всё

--------»«---------------
!
aaa new-model
!
aaa authentication attempts login 5
aaa authentication login default local
aaa authentication ppp pppoe_clients group radius local
aaa authorization exec default local 
aaa authorization network default group radius if-authenticated 
aaa authorization network pppoe_clients group radius 
aaa accounting send stop-record authentication failure 
aaa accounting delay-start all
aaa accounting update periodic 1
aaa accounting exec pppoe_clients start-stop group radius
aaa accounting network pppoe_clients start-stop group radius
!
aaa server radius dynamic-author
 client 192.168.xxx.xxx
 server-key *****
 auth-type any
!
aaa session-id common 
!
--------»«---------------
!
vpdn enable
!
--------»«---------------
!
bba-group pppoe global
 virtual-template 1
 sessions max limit 8000
 sessions per-mac limit 1
 sessions per-vlan limit 500
 sessions auto cleanup
!
interface FastEthernet0/0
 description -=Local Network=-
 ip address 192.168.xxx.xxx 255.255.255.0
 ip virtual-reassembly
 duplex auto
 speed auto
 pppoe enable group global
!
--------»«---------------
!
interface Virtual-Template1 
 ip unnumbered FastEthernet0/1
 ip mtu 1492
 autodetect encapsulation ppp
 peer default ip address pool adsl
 ppp max-bad-auth 3
 ppp authentication chap pap pppoe_clients
 ppp authorization pppoe_clients
 ppp accounting pppoe_clients
 ppp ipcp dns 192.168.xxx.xxx
 ppp timeout retry 3
 ppp timeout authentication 45
 ppp timeout idle 3600
!
--------»«---------------
!
ip radius source-interface FastEthernet0/0
!
radius-server attribute 44 include-in-access-req
radius-server attribute 44 extend-with-addr
radius-server attribute 6 on-for-login-auth
radius-server attribute 8 include-in-access-req
radius-server attribute 32 include-in-access-req 
radius-server attribute nas-port format e UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
radius-server attribute 31 mac format ietf
radius-server configure-nas
radius-server host 192.168.xxx.xxx auth-port 1812 acct-port 1813
radius-server retransmit 5
radius-server key ********
radius-server vsa send cisco-nas-port
radius-server vsa send accounting
radius-server vsa send authentication 
!
--------»«---------------
Найчастіше на форумах рекомендують збільшити значення max_servers в radiusd.conf та radius-server timeout у налаштуваннях Cisco. Зараз на Cisco:

Код: Выделить всё

aaa accounting update periodic 3
radius-server timeout 120
Acct-Interim-Interval та Alive відповідно змінив на 180. Якщо в когось є ще якісь ідеї по оптимізації конфігів Сisco та FreeRadius -- буду радий побачити їх до 01.03.2011, оскільки 28.02 планую у ночі бути на роботі.
Запустити radius з rlm_perl мені так і не вдалося, хоча пробував різні версії як freeradius так і perl...
Час летить швидко, але є хороша новина -- ти в кріслі пілота!

yuracher
Сообщения: 63
Зарегистрирован: Вт авг 11, 2009 6:56 am
Откуда: Коломия
Контактная информация:

Re: Radius пишет Error: Discarding duplicate request from cl

Сообщение yuracher » Вт мар 01, 2011 9:14 am

yuracher писал(а):...Найчастіше на форумах рекомендують збільшити значення max_servers в radiusd.conf та radius-server timeout у налаштуваннях Cisco. Зараз на Cisco:

Код: Выделить всё

aaa accounting update periodic 3
radius-server timeout 120
Acct-Interim-Interval та Alive відповідно змінив на 180.
Трохи допомогло! В ніч на перше березня нічого критичного не сталося. Однак в логи FreeRadius посипалось 11 рядків наступного вмісту:

Код: Выделить всё

Tue Mar  1 00:00:22 2011 : Info: The maximum number of threads (64) are active, cannot spawn new thread to handle request
Tue Mar  1 00:00:26 2011 : Info: The maximum number of threads (64) are active, cannot spawn new thread to handle request
Tue Mar  1 00:00:26 2011 : Info: The maximum number of threads (64) are active, cannot spawn new thread to handle request
Tue Mar  1 00:00:26 2011 : Info: The maximum number of threads (64) are active, cannot spawn new thread to handle request
Tue Mar  1 00:00:26 2011 : Info: The maximum number of threads (64) are active, cannot spawn new thread to handle request
Tue Mar  1 00:00:26 2011 : Info: The maximum number of threads (64) are active, cannot spawn new thread to handle request
Tue Mar  1 00:00:28 2011 : Info: The maximum number of threads (64) are active, cannot spawn new thread to handle request
Tue Mar  1 00:00:29 2011 : Info: The maximum number of threads (64) are active, cannot spawn new thread to handle request
Tue Mar  1 00:00:29 2011 : Info: The maximum number of threads (64) are active, cannot spawn new thread to handle request
Tue Mar  1 00:00:29 2011 : Info: The maximum number of threads (64) are active, cannot spawn new thread to handle request
Tue Mar  1 00:00:30 2011 : Info: The maximum number of threads (64) are active, cannot spawn new thread to handle request
В наслідок цього виникає питання чи варто збільшувати max_servers якщо використовується rlm_exec? Також цікавить чи повинно значення max_request_time в radiusd.conf співпадати з radius-server timeout в налаштуваннях cisco?
Час летить швидко, але є хороша новина -- ти в кріслі пілота!

~AsmodeuS~
Site Admin
Сообщения: 5707
Зарегистрирован: Пт янв 28, 2005 3:11 pm
Контактная информация:

Re: Radius пишет Error: Discarding duplicate request from cl

Сообщение ~AsmodeuS~ » Ср июн 29, 2011 8:29 am

параметр max_clones

Кузьменко
Сообщения: 25
Зарегистрирован: Сб мар 16, 2013 10:13 am

Re: Radius пишет Error: Discarding duplicate request from cl

Сообщение Кузьменко » Вс апр 14, 2013 9:50 pm

У меня та же проблема при автозапуске radius:

Mon Apr 15 00:42:20 2013 : Error: Discarding duplicate request from client other:50589 - ID: 41 due to unfinished request 0
Mon Apr 15 00:42:20 2013 : Error: Discarding duplicate request from client other:50589 - ID: 41 due to unfinished request 0
Mon Apr 15 00:42:22 2013 : Error: Discarding duplicate request from client other:47609 - ID: 42 due to unfinished request 1
Mon Apr 15 00:42:22 2013 : Error: Discarding duplicate request from client other:47609 - ID: 42 due to unfinished request 1
Mon Apr 15 00:42:37 2013 : Error: Discarding duplicate request from client other:56370 - ID: 43 due to unfinished request 2
Mon Apr 15 00:42:37 2013 : Error: Discarding duplicate request from client other:56370 - ID: 43 due to unfinished request 2
Mon Apr 15 00:45:39 2013 : Error: Discarding duplicate request from client other:45108 - ID: 44 due to unfinished request 3

radiusd -X - все работает

так в чем же причина?

~AsmodeuS~
Site Admin
Сообщения: 5707
Зарегистрирован: Пт янв 28, 2005 3:11 pm
Контактная информация:

Re: Radius пишет Error: Discarding duplicate request from cl

Сообщение ~AsmodeuS~ » Пн апр 15, 2013 7:05 am

не успевает радиус обработать запрос и отбрасывает дубликат запроса от клиента до до вершения первого запроса

увеличить время между запросами

radius set timeout=хххх

Ответить