вопрос новичка

Установка, настройка, поддержка
worky
Сообщения: 67
Зарегистрирован: Пт мар 13, 2009 6:41 pm

вопрос новичка

Сообщение worky » Пт мар 13, 2009 6:47 pm

Меня тут попросили глянуть на один сервачок с абиллсом. и возник вопрос. а именно - как определить версию абиллс?
в веб фейсе пишется что версия 0.32б. при этом изменений и дополнительных таблиц для версий выше в БД нет. НО! в файле чейнжлог последней стоит версия 0.37. у меня сложилось мнение, что 0.37 наложили сверху, но БД под нее не переделывали.
где еще можно глянуть инфу для идентификации абиллса?

lasik
Сообщения: 983
Зарегистрирован: Чт янв 10, 2008 5:20 pm
Откуда: Россия, Москва

Сообщение lasik » Пн мар 16, 2009 8:33 am

простой наливкой, дополнений в базу, он тебе не даст добавить то, чего нет

worky
Сообщения: 67
Зарегистрирован: Пт мар 13, 2009 6:41 pm

Сообщение worky » Вт мар 17, 2009 7:04 pm

lasik писал(а):простой наливкой, дополнений в базу, он тебе не даст добавить то, чего нет
а подробнее можно. непонятно :oops:

lasik
Сообщения: 983
Зарегистрирован: Чт янв 10, 2008 5:20 pm
Откуда: Россия, Москва

Сообщение lasik » Ср мар 18, 2009 8:18 pm

у мя на всех серверах стоит такой менеджер как webmin
в нем я перехожу в mysql, выбираю базу абиллса, далее нажимаю Исполнение SQL, и вставляю туда по 1 строчке из ченж лога b jnghfdkz. yf dsgjkytybt

Пример
вот это ченж лог за 9 января
тут целых 4 строки

Код: Выделить всё

ALTER TABLE tarif_plans ADD COLUMN  postpaid_daily_fee tinyint(1) unsigned NOT NULL default '0';
ALTER TABLE tarif_plans ADD COLUMN  postpaid_monthly_fee tinyint(1) unsigned NOT NULL default '0';
UPDATE tarif_plans SET postpaid_daily_fee=postpaid_fee, postpaid_monthly_fee=postpaid_fee;
ALTER TABLE  abon_tariffs ADD COLUMN `period_alignment` tinyint(1) NOT NULL DEFAULT '0';
выделяю 1 и пихаю ее в окно вебмина, и на исполнение нажимаю, если не выругался, значит данные еще не присутствовали.

Я знаю что это грубо и медлено, но достаточно эфективно

worky
Сообщения: 67
Зарегистрирован: Пт мар 13, 2009 6:41 pm

Сообщение worky » Чт мар 19, 2009 7:17 pm

а потом если чо - накатывается на скрипты биллинга обновления?

lasik
Сообщения: 983
Зарегистрирован: Чт янв 10, 2008 5:20 pm
Откуда: Россия, Москва

Сообщение lasik » Чт мар 19, 2009 8:39 pm

сами файлы биллинга, точнее сказать всю папку, можно тупо новую, списав логин/пасс мускуля, и все

lasik
Сообщения: 983
Зарегистрирован: Чт янв 10, 2008 5:20 pm
Откуда: Россия, Москва

Сообщение lasik » Чт мар 19, 2009 8:40 pm

еще, воть эту строку незабудь проверить

$conf{secretkey}="test12345678901234567890";

если она отличается, ее то же нужно сохранить

worky
Сообщения: 67
Зарегистрирован: Пт мар 13, 2009 6:41 pm

Сообщение worky » Пт мар 20, 2009 11:13 am

а с версии 0.3х и до 0.4х так же можно обновиться? никаких граблей нет?
и еще - есть ли где инфа, для каких версий Абиллса какие версии прог нужны? а именно - нужно ли что-то обновлять из пппд и пр серверов при обновлении до версии 0.4?
просто может для 0.4х нужно и версии серверов обновлять. а мне нужно будет с 0.32 до 0.4 обновить систему. поэтому интересно - не будет ли каких граблей с этими серверами....

lasik
Сообщения: 983
Зарегистрирован: Чт янв 10, 2008 5:20 pm
Откуда: Россия, Москва

Сообщение lasik » Пт мар 20, 2009 8:30 pm

радиус точно до 1,7 обновлять, а остальное вроде нормик

worky
Сообщения: 67
Зарегистрирован: Пт мар 13, 2009 6:41 pm

Сообщение worky » Чт апр 02, 2009 7:21 pm

тренируюсь на кошках! поэтому есть вопросы:
1) при добавлении запросов в базы пишет ошибки. судя по всему ошибки для таблиц, которых нет в БД. на них не обращать внимания?
2) что делать с конфигом? в новых версиях в него добавляются новые значения. как его правильно обновить? или там только логин/пасс к базе и фраза для кодировки нужны?

lasik
Сообщения: 983
Зарегистрирован: Чт янв 10, 2008 5:20 pm
Откуда: Россия, Москва

Сообщение lasik » Чт апр 02, 2009 8:18 pm

1 не обращать внимание.
2с каким именно конфигом ?

worky
Сообщения: 67
Зарегистрирован: Пт мар 13, 2009 6:41 pm

Сообщение worky » Чт апр 02, 2009 9:04 pm

lasik писал(а):1 не обращать внимание.
2с каким именно конфигом ?
конфигом биллинга - config.pl

lasik
Сообщения: 983
Зарегистрирован: Чт янв 10, 2008 5:20 pm
Откуда: Россия, Москва

Сообщение lasik » Пт апр 03, 2009 5:30 am

там меняете логин пас, название базы и ключ базы, если у вас что то отличается, и все

ran
Сообщения: 2298
Зарегистрирован: Вс окт 21, 2007 2:29 pm

Сообщение ran » Пт апр 03, 2009 11:46 am

мне нужно будет с 0.32 до 0.4 обновить систему
0.32 ну уж очень древняя версия и давно не поддерживается... думаю проще всего сделать так:

1. сделать дамп текущей базы
2. грохнуть её
3. поставить с нуля из каррент
4. в дампе базы закомментировать/поудалять команды DROP TABLE IF EXISTS... и CREATE TABLE...
5. залить отредактированный дамп в новую базу
Любой тупик - это тщательно замаскированный выход.

worky
Сообщения: 67
Зарегистрирован: Пт мар 13, 2009 6:41 pm

Сообщение worky » Пт апр 24, 2009 12:02 pm

обновил абиллс с 0.3х до 0.41 - вылезли грабли:
1) отпало ограничение скорости
не подскажите - куда рыть? что смотреть?
server:~# tc qdisc sh dev ppp4
qdisc pfifo_fast 0: bands 3 priomap 1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
вот такое ставится на фейсах. классов вообще нет. пытался новый тариф завести - то же.

2)поменялась подсеть для фейсов - была 172.16.1.0, а стало 192.168.1.0.
вот как выглядит теперь фейс на серваке:
ppp15 Link encap:Point-to-Point Protocol
inet addr:172.16.1.1 P-t-P:192.168.1.15 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1400 Metric:1
RX packets:3528 errors:0 dropped:0 overruns:0 frame:0
TX packets:3334 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:416634 (406.8 KiB) TX bytes:2266987 (2.1 MiB)

а раньше P-t-P был из подсети 172.16.1х
куда рыть?

Ответить