Подключить mikrotik в роли nas в Abills

Платформа Mikrotik
Ответить
StartTest
Сообщения: 15
Зарегистрирован: Пн ноя 11, 2013 6:11 pm

Подключить mikrotik в роли nas в Abills

Сообщение StartTest » Пн дек 02, 2013 5:07 am

Подскажите какие настройки в abills должны быть для подключения в роли nas оборудования mikrotik rb1100(pppoe)
в конфиге freeradius в файле clients.conf добавил запись типа:

Код: Выделить всё

client MikrotikIP {
   secret = maxsecret
   shortname = MikrotikIP(dyndns имя почему то ему не понравилось)
} 

В поле secret содержится ключ по которому шифруется пароль? или это и есть сам пароль который нужно указать на Mikrotike в настройках radius.


Изображение

immortality
Сообщения: 52
Зарегистрирован: Ср мар 14, 2012 8:11 pm
Контактная информация:

Re: Подключить mikrotik в роли nas в Abills

Сообщение immortality » Чт дек 05, 2013 1:39 pm

Настройки тут

StartTest
Сообщения: 15
Зарегистрирован: Пн ноя 11, 2013 6:11 pm

Re: Подключить mikrotik в роли nas в Abills

Сообщение StartTest » Чт дек 12, 2013 7:48 pm

Код: Выделить всё

/ip traffic-flow set enabled=yes
/ip traffic-flow target add address=10.0.0.10:9996 version=5
/ip traffic-flow set interfaces=ether3 active-flow-timeout=30m inactive-flow-timeout=15s cache-entries=4k enabled=yes ;
10.0.0.10 адрес сервера это сервер на котором установлен Abills? если у меня на микротике на каждом порту по pppoe серверу? а сам сервер на котором установлен Abills в другой сети и у него белый Ip. то запись должна принять вид(может в синтаксисе не верно что то)

Код: Выделить всё

/ip traffic-flow set enabled=yes
/ip traffic-flow target add address=[b]мойбелыйip:9996[/b] version=5
/ip traffic-flow set interfaces=[b]ether1-ether12[/b] active-flow-timeout=30m inactive-flow-timeout=15s cache-entries=4k enabled=yes ;
все верно или нет? что я должен буду увидеть в логах abills при удачной настройке?

immortality
Сообщения: 52
Зарегистрирован: Ср мар 14, 2012 8:11 pm
Контактная информация:

Re: Подключить mikrotik в роли nas в Abills

Сообщение immortality » Пт дек 13, 2013 2:25 pm

Ну и зачем вам это? это нужно для ipn (ipoe) а у вас вопрос был про pppoe

Код: Выделить всё

Подскажите какие настройки в abills должны быть для подключения в роли nas оборудования mikrotik rb1100(pppoe)
вам из мануала не нужны пункты про ipn и dhcp

StartTest
Сообщения: 15
Зарегистрирован: Пн ноя 11, 2013 6:11 pm

Re: Подключить mikrotik в роли nas в Abills

Сообщение StartTest » Сб дек 14, 2013 4:43 pm

Код: Выделить всё

[Sat Dec 14 18:06:10 2013] [error] [client ip] DBD::mysql::db do failed: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '12345678901234567890' at line 1 at ../../Abills/mysql//main.pm line 73., referer: https://ip:9443/admin/index.cgi?index=64
подскажите сменил пароль пользователю abills, и перестало пускать в админку, в логах вот что. открыл main.pm 73 строчку, глянул не удачный конект к мускулю вот и ругается походу... подскажите как исправить? пароль на админку ввожу верно 100%.

~AsmodeuS~
Site Admin
Сообщения: 5592
Зарегистрирован: Пт янв 28, 2005 3:11 pm
Контактная информация:

Re: Подключить mikrotik в роли nas в Abills

Сообщение ~AsmodeuS~ » Вт дек 17, 2013 8:56 am

неправильно заполнили переменные $conf{dbcharset}

StartTest
Сообщения: 15
Зарегистрирован: Пн ноя 11, 2013 6:11 pm

Re: Подключить mikrotik в роли nas в Abills

Сообщение StartTest » Вс мар 09, 2014 1:22 pm

Скажите как верно завести тарифные планы?

Делаю все как в этом видео: http://www.youtube.com/watch?v=MBiHmTHqL38
1.Cистема-> интернет тарифные планы->ввожу номер(произвольно) и название тарифного плана и жму добавить.
2.Клацаю внизу в списке на этом тарифном плане на значке интервалы(часы) просто жму добавить.
3.Далее в строке интервала(вверху) жму на значке трафика(диаграмма) в строепх IN и OUT указываю к примеру 1024 и жму кнопку добавить.
4.Затем выполняю:
/usr/abills/libexec/billd checkspeed mikrotik
На микротике появляются (очереди)правила:

Код: Выделить всё

    /queue type
add kind=pcq name=TP_4_in_global_speed pcq-classifier=src-address pcq-rate=5144576
add kind=pcq name=TP_4_out_global_speed pcq-classifier=dst-address pcq-rate=5144576
5. Завожу pool в abills:

6.Далее завожу пользователя, выбираю ему этот тарифный план.

radiusd -X при авторизации:

Код: Выделить всё

 Service-Type = Framed-User
        Framed-Protocol = PPP
        NAS-Port = 145
        NAS-Port-Type = Ethernet
        User-Name = "SOMEUSERLOGIN"
        Calling-Station-Id = "C0:4A:00:34:AB:6F"
        Called-Station-Id = "service1"
        NAS-Port-Id = "bridge-local"
        Acct-Session-Id = "81100084"
        Framed-IP-Address = 10.0.0.22
        Acct-Authentic = RADIUS
        Event-Timestamp = "Mar  3 2014 06:26:30 UTC"
        Acct-Session-Time = 0
        Acct-Input-Octets = 72
        Acct-Input-Gigawords = 0
        Acct-Input-Packets = 6
        Acct-Output-Octets = 94
        Acct-Output-Gigawords = 0
        Acct-Output-Packets = 7
        Acct-Status-Type = Stop
        Acct-Terminate-Cause = NAS-Error
        NAS-Identifier = "MikroTik"
        Acct-Delay-Time = 0
        NAS-IP-Address = 192.168.0.5
# Executing section preacct from file /usr/local/etc/raddb/sites-enabled/abills_default
+- entering group preacct {...}
++[preprocess] returns ok
# Executing section accounting from file /usr/local/etc/raddb/sites-enabled/abills_default
+- entering group accounting {...}
rlm_perl: Added pair Acct-Input-Octets = 72
rlm_perl: Added pair NAS-Port-Type = Ethernet
rlm_perl: Added pair Acct-Session-Id = 81100084
rlm_perl: Added pair Acct-Output-Gigawords = 0
rlm_perl: Added pair Service-Type = Framed-User
rlm_perl: Added pair Called-Station-Id = service1
rlm_perl: Added pair Acct-Authentic = RADIUS
rlm_perl: Added pair Acct-Status-Type = Stop
rlm_perl: Added pair Acct-Output-Packets = 7
rlm_perl: Added pair NAS-IP-Address = 192.168.0.5
rlm_perl: Added pair NAS-Port-Id = bridge-local
rlm_perl: Added pair Acct-Output-Octets = 94
rlm_perl: Added pair Acct-Terminate-Cause = NAS-Error
rlm_perl: Added pair Acct-Session-Time = 0
rlm_perl: Added pair Calling-Station-Id = C0:4A:00:34:AB:6F
rlm_perl: Added pair Framed-Protocol = PPP
rlm_perl: Added pair User-Name = "SOMEUSERLOGIN"
rlm_perl: Added pair NAS-Identifier = MikroTik
rlm_perl: Added pair Event-Timestamp = Mar  3 2014 06:26:30 UTC
rlm_perl: Added pair Acct-Input-Gigawords = 0
rlm_perl: Added pair Framed-IP-Address = 10.0.0.22
rlm_perl: Added pair Acct-Input-Packets = 6
rlm_perl: Added pair NAS-Port = 145
rlm_perl: Added pair Acct-Delay-Time = 0
++[perl] returns ok
Sending Accounting-Response of id 157 to ABILLSSRVIPADDRESS port 32910
Finished request 5.
Cleaning up request 5 ID 157 with timestamp +6
Going to the next request
Waking up in 1.1 seconds.
Cleaning up request 0 ID 152 with timestamp +2
Waking up in 3.7 seconds.
при попытке авторизации в логах микротика:

Код: Выделить всё

19:05:19 pppoe,info PPPoE connection established from 11:AE:ED:83:D0:0F 
19:05:19 pppoe,ppp,info <pppoe-0>: waiting for call... 
19:05:19 pppoe,ppp,info <pppoe-0>: authenticated 
19:05:19 pppoe,ppp,info <pppoe-0>: terminating... - could not determine remote IP address 
19:05:19 pppoe,ppp,info <pppoe-0>: disconnected
Подскажите что пропустил! или выполнил не верно!
Вложения
post-601-0-21756600-1393399644_thumb.jpg
Выбираю Pool
post-601-0-21756600-1393399644_thumb.jpg (20.85 КБ) 6222 просмотра
1234.jpg
Pool Abills
1234.jpg (27.17 КБ) 6222 просмотра

~AsmodeuS~
Site Admin
Сообщения: 5592
Зарегистрирован: Пт янв 28, 2005 3:11 pm
Контактная информация:

Re: Подключить mikrotik в роли nas в Abills

Сообщение ~AsmodeuS~ » Вс мар 16, 2014 5:11 pm

пропустили указать пул адресов на сервер доступа

Ответить