Микротик + абиллс

gekz
Сообщения: 169
Зарегистрирован: Пн май 17, 2010 7:30 am

Микротик + абиллс

Сообщение gekz »

на данный момент всё работает в связке
фриха 8-я, радиус 1, мпд5, абиллс последний
потребовалось значит на радиусе проводить авторизацию
из другой сети
в логах радиуса строчки типа дубликат трали вали
выяснил что радиусу не нравится когда в одной сети запущено 2 сервера пппое
те мпд5 и микротик, у которого в качестве авторизации стоит радиус сервака
отключение мпд на уже хорошо отлаженной тачке как то не канает
может есть какое то решение, как использовать уже готовый радиус-биллинг-мпд + микротик
или может я микротик не так отконфигурил?

~AsmodeuS~
Site Admin
Сообщения: 5721
Зарегистрирован: Пт янв 28, 2005 3:11 pm
Контактная информация:

Re: Микротик + абиллс

Сообщение ~AsmodeuS~ »

так и не понятно в чём причина?

gekz
Сообщения: 169
Зарегистрирован: Пн май 17, 2010 7:30 am

Re: Микротик + абиллс

Сообщение gekz »

есть задача
стоит сервер на котором крутится фирибсд-радиус-мпд5-абиллс
на другом конце города, скажем так появился узел с кучей клиентов и провод от провайдера
что бы не мутить этот узел в одну сеть, установил микротик у которого поднял пппое сервер и указал в качестве авторизации радиус сервер на биллинге
добавил в биллинг тестового юзера и попытался зайти под ним
на что радиус сервер сказал, что в сети есть 2 пппое сервера, идите все вон
и не в какую

на тестовой машине проделал то же самое
но на сервере с биллингом отключил мпд
и всё стало ок

Moose
Сообщения: 61
Зарегистрирован: Чт дек 24, 2009 4:45 pm
Откуда: Planet Earth

Re: Микротик + абиллс

Сообщение Moose »

что то не понятно
Вы создали на билинге 2 НАСа один МПД второй Микротик?

~AsmodeuS~
Site Admin
Сообщения: 5721
Зарегистрирован: Пт янв 28, 2005 3:11 pm
Контактная информация:

Re: Микротик + абиллс

Сообщение ~AsmodeuS~ »

нужно чтоыб вы показали логи ато тяжело определить ситуацию по то туву что вы продуэте цитировать радиус сервер

gekz
Сообщения: 169
Зарегистрирован: Пн май 17, 2010 7:30 am

Re: Микротик + абиллс

Сообщение gekz »

связал абилса с микротиком
:D
обновил прошивку на микротике до последней 5.03рс
и всё заработало, видать что то поправили в лучшую сторону)))
стояла 4.09
поставил сперва 5.01рс, не завелось, да и вообще микротик жутко тупил
на 5.03 всё гуд




гранаты у него не той системы(с)
Последний раз редактировалось gekz Пн ноя 01, 2010 10:37 pm, всего редактировалось 1 раз.

gekz
Сообщения: 169
Зарегистрирован: Пн май 17, 2010 7:30 am

Re: Микротик + абиллс

Сообщение gekz »

Moose писал(а):что то не понятно
Вы создали на билинге 2 НАСа один МПД второй Микротик?
да
два НАСа


в общем так
есть сервак
2 сетевухи
лан - 172.х.х.х/24
ван - 10.10.х.х/16

локально крутится мпд+радиус работает на юзеров из сети лан. те с лан"ом проблем нет
задача
с внешки приходят запросы на сервак и спрашивают у радиуса за юзеров
на микротике прописан в качестве радиуса адрес внешней сетвухи сервака
вот за эту тему отвечает микротик
те не охота мутить ещё один сервак с билингом, когда уже есть :)

у нас глобальная сеть это 10-я
те все районы в ней
на каждом районе стоит микротик и провод до прова
те сколько районов юзаем, столько линков
на микротиках в качестве радиус сервера указан сервак с билингом
который виден отовсюду
так вот надо авторизоваться на билинге, а юзать прова на своём районе :)

блин чёта сложно написал :roll:

gekz
Сообщения: 169
Зарегистрирован: Пн май 17, 2010 7:30 am

Re: Микротик + абиллс

Сообщение gekz »

не смог пока победить тарификацию по классам

Код: Выделить всё

friha# /usr/abills/libexec/linkupdown mikrotik up em0 gekz NAS_HOST=192.168.88.20 NAS_ADMIN=admin_ssh ssh pppoe debug
Count:  0 Remain Time: 0
Day: 0 Session_start: 37409 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  1 Remain Time: 48991
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  2 Remain Time: 135391
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  3 Remain Time: 221791
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  4 Remain Time: 308191
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  5 Remain Time: 394591
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  6 Remain Time: 480991
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  7 Remain Time: 567391
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  8 Remain Time: 653791
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  9 Remain Time: 740191
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  10 Remain Time: 826591
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  11 Remain Time: 912991
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  12 Remain Time: 999391
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  13 Remain Time: 1085791
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  14 Remain Time: 1172191
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  15 Remain Time: 1258591
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  16 Remain Time: 1344991
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  17 Remain Time: 1431391
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  18 Remain Time: 1517791
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  19 Remain Time: 1604191
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  20 Remain Time: 1690591
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  21 Remain Time: 1776991
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  22 Remain Time: 1863391
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  23 Remain Time: 1949791
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  24 Remain Time: 2036191
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  25 Remain Time: 2122591
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  26 Remain Time: 2208991
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  27 Remain Time: 2295391
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  28 Remain Time: 2381791
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  29 Remain Time: 2468191
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  30 Remain Time: 2554591
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  31 Remain Time: 2640991
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  32 Remain Time: 2727391
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  33 Remain Time: 2813791
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  34 Remain Time: 2900191
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  35 Remain Time: 2986591
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  36 Remain Time: 3072991
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  37 Remain Time: 3159391
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  38 Remain Time: 3245791
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  39 Remain Time: 3332191
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  40 Remain Time: 3418591
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  41 Remain Time: 3504991
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  42 Remain Time: 3591391
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  43 Remain Time: 3677791
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  44 Remain Time: 3764191
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  45 Remain Time: 3850591
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  46 Remain Time: 3936991
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  47 Remain Time: 4023391
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  48 Remain Time: 4109791
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
Count:  49 Remain Time: 4196191
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 16
 <<!=
TT, 16
TIME_PRICE, 0
FIRST_INTERVAL, 16
Expresion:================================

END: =====================================
The authenticity of host '192.168.88.20 (192.168.88.20)' can't be established.
RSA key fingerprint is 39:b8:d9:c2:c2:ac:e9:8a:b9:b9:67:17:30:1a:3a:42.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.88.20' (RSA) to the list of known hosts.
Password:
Password:
Password:
Permission denied (publickey,keyboard-interactive).
 /ip firewall mangle add chain=forward out-interface=<pptp-gekz> action=mark-packet new-packet-mark=TT_5_0_gekz_mark_in comment=TT_5_0_gekz_mark_in passthrough=yes
Password:
Password:
Password:
Permission denied (publickey,keyboard-interactive).
 /ip firewall mangle add chain=forward in-interface=<pptp-gekz> action=mark-packet new-packet-mark=TT_5_0_gekz_mark_out comment=TT_5_0_gekz_mark_out passthrough=yes
Password:
Password:
Password:
Permission denied (publickey,keyboard-interactive).
 /queue tree add name=TT_5_0_gekz_mark_in parent=<pptp-gekz> packet-mark=TT_5_0_gekz_mark_in limit-at=307200 max-limit=307200 queue=default-small priority=8 burst-limit=0

Password:
Password:
Password:
Permission denied (publickey,keyboard-interactive).
 /queue tree add name=TT_5_0_gekz_mark_out parent=global-out packet-mark=TT_5_0_gekz_mark_out limit-at=307200 max-limit=307200 queue=default-small priority=8 burst-limit=0

Password:
Password:
Password:
Permission denied (publickey,keyboard-interactive).
что то не может скрипт запилить в микротик всё необходимое
хотя подключаюсь клиентом, всё микротике прописывается
скорость режется, со стороны кажется что всё ок
но вот по классам никак не получилось
вижу что что то с ключами
но что никак не пойму
вроде всё делал как мане(((((
в папке /root/.ssh появляется файлик, типа неизвестный хост
грохаю его, в дебакг снова просит пройти ферификацию
и постояк просит пароль
хотя сертификат создавал пустой

что не так?
или может у кого такое было, подскажите как победили?
возникла необходимосмть не резать трафик на внутреннюю сеть провайдера

~AsmodeuS~
Site Admin
Сообщения: 5721
Зарегистрирован: Пт янв 28, 2005 3:11 pm
Контактная информация:

Re: Микротик + абиллс

Сообщение ~AsmodeuS~ »

сертификат не подходит

gekz
Сообщения: 169
Зарегистрирован: Пн май 17, 2010 7:30 am

Re: Микротик + абиллс

Сообщение gekz »

~AsmodeuS~ писал(а):сертификат не подходит
хм
делаю по мануалу

Код: Выделить всё

# ./certs_create.sh ssh admin
**************************************************************************
Creating SSH authentication Key
 Make ssh-keygen with empty password.
**************************************************************************

Generating public/private dsa key pair.
Enter passphrase (empty for no passphrase):
Enter same passphrase again:
Your identification has been saved in /usr/abills/Certs/id_dsa.admin.
Your public key has been saved in /usr/abills/Certs/id_dsa.admin.pub.
The key fingerprint is:
65:94:a5:0b:99:d4:48:44:c6:6d:fd:e7:0e:70:83:c2 ABillS remote machine manage key (Mon Nov  8 16:54:39 VLAT 2010)
The key's randomart image is:
+--[ DSA 1024]----+
|       =*+.+.    |
|       oo+=..    |
|        +o+  o   |
|         +E.o + .|
|        S .. o + |
|              . .|
|               o |
|                .|
|                 |
+-----------------+
Set Cert user:
Upload file to remote host (y/n): n

Copy /usr/abills/Certs/id_dsa.admin.pub to REMOTE_HOST User home dir (/home/admin/.ssh/authorized_keys)

ssh Done...
Enter passphrase (empty for no passphrase):
Enter same passphrase again:
тут жмём ентер и всё
затем заливаем в микротик к в мане и не работает :(
что ещё не так может быть?

думается вот в этом

Код: Выделить всё

Upload file to remote host (y/n): n
надо прежде чем создавать сертификат, завести пользователя в микротике
потом сказать да и залить ему сертификат
может так?
вечером сегодня буду пробывать

gekz
Сообщения: 169
Зарегистрирован: Пн май 17, 2010 7:30 am

Re: Микротик + абиллс

Сообщение gekz »

очень странная штука получается
сижу мониторю момент подключения узера
и вижу вот это
Безымянный.JPG
Безымянный.JPG (112.64 КБ) 8749 просмотров
потом это всё чудным образом через секунду пропадает
и остаётся только запись
Безымянный2.JPG
Безымянный2.JPG (63.71 КБ) 8749 просмотров
куда копать? и что это может быть?
может не так прописаны сети?

gekz
Сообщения: 169
Зарегистрирован: Пн май 17, 2010 7:30 am

Re: Микротик + абиллс

Сообщение gekz »

и ещё
если делать всё это с консоли, то добавляется всё чётко, кроме симплов
те в дерево - две записи, метки и тд.
чёт не могу я понять этот механизм
а подсказать похоже не кому(((((

gekz
Сообщения: 169
Зарегистрирован: Пн май 17, 2010 7:30 am

Re: Микротик + абиллс

Сообщение gekz »

и ещё
пользователю постояк прописывается сид
хотя всё настроено что бы не писать в это поле ничего
это микротик пишет или билинг?
как отключить?

Silver Ghost
Сообщения: 173
Зарегистрирован: Ср апр 11, 2007 6:22 am
Контактная информация:

Re: Микротик + абиллс

Сообщение Silver Ghost »

поставить ANY не позволяет религия?

gekz
Сообщения: 169
Зарегистрирован: Пн май 17, 2010 7:30 am

Re: Микротик + абиллс

Сообщение gekz »

Silver Ghost писал(а):поставить ANY не позволяет религия?
ты о чём?
не совсем понял.

Ответить