Классы траффика

Ответить
smilethebest
Сообщения: 42
Зарегистрирован: Пн сен 21, 2009 8:09 am

Классы траффика

Сообщение smilethebest » Вт янв 05, 2010 6:35 am

народ помогите разобраться с полем Nets, надо на определённые подсети снять лимиты по скорости, или сделать отличные от Global скорости. как это можно организовать?
Mikrotik 4.3 abills 0.5

подробно:
имеем сети нашего казахстанского провайдера к примеру 8.8.8.8/24, как делать на эту определённую подсеть скорости в тарифном плане не ограниченные? а на весь остальной инет 1024.
Спасибо :)
или как я понял эта функция только для EXPPP?
"Ограничение скорости в зависимости от класса трафика (Только для NAS exppp)"
???

ran
Сообщения: 2298
Зарегистрирован: Вс окт 21, 2007 2:29 pm

Re: Классы траффика

Сообщение ran » Вт янв 05, 2010 8:57 am

имеем сети нашего казахстанского провайдера к примеру 8.8.8.8/24, как делать на эту определённую подсеть скорости в тарифном плане не ограниченные? а на весь остальной инет 1024.
где-то так:

/ Система/ Internet/ Тарифные планы/ Интервалы/

Код: Выделить всё

Тарифы трафика
#	In 	Out 	Предоплата	Скорость IN	Скорость OUT	DESCRIBE	NETS	-	-
1	0.00000	0.00000	0	0	0	Локальный	8.8.8.0/24 
0	0.00000	0.00000	0	1024	1024	Интернет	0.0.0.0/0
не знаю как там с микротиком а под линухом и бздёй работает
Любой тупик - это тщательно замаскированный выход.

smilethebest
Сообщения: 42
Зарегистрирован: Пн сен 21, 2009 8:09 am

Re: Классы траффика

Сообщение smilethebest » Вт янв 05, 2010 10:31 am

под микротиком что то не наблюдается шэйпера по классам траффика...
разработчики? что скажете? авторизация по радиусу само собой :)

ran
Сообщения: 2298
Зарегистрирован: Вс окт 21, 2007 2:29 pm

Re: Классы траффика

Сообщение ran » Вт янв 05, 2010 11:12 am

а linkupdown при при поднятии/опускании туннеля запускаем? по крайней мере какой-то код там есть по микротику, не анализировал. он должен сгенерить последовательность команд настройки шейпера и по ссш настроить шейпер микротика... запустить linkupdown в дебаге с нужными параметрами и смотреть что он там тебе нагенерит на консоль
Любой тупик - это тщательно замаскированный выход.

~AsmodeuS~
Site Admin
Сообщения: 5707
Зарегистрирован: Пт янв 28, 2005 3:11 pm
Контактная информация:

Re: Классы траффика

Сообщение ~AsmodeuS~ » Вт янв 05, 2010 1:29 pm

linkupdown

smilethebest
Сообщения: 42
Зарегистрирован: Пн сен 21, 2009 8:09 am

Re: Классы траффика

Сообщение smilethebest » Чт янв 07, 2010 11:16 am

так. тут по подробней как посмотреть выполняется ли linkupdown? и как посмотреть его debug?
да и кстате скрипт /usr/abills/libexec/ext_acct mikrotik_mshaper.sh вот этот настроен вроде правильно...

ran
Сообщения: 2298
Зарегистрирован: Вс окт 21, 2007 2:29 pm

Re: Классы траффика

Сообщение ran » Чт янв 07, 2010 2:32 pm

так. тут по подробней как посмотреть выполняется ли linkupdown?
эхх... конспиратор... ось то у тебя хоть какая на биллинге? ясновидящие все НГ ещё отмечают ;) если линух - то если вызываешь сам из скриптов up/down ppp туннелей - то выполняется, если нет - то канешна нет :D а если не линух - то это не ко мне ;)
и как посмотреть его debug?
заглянуть в евойный исподник и увидеть что там есть опция debug... а можно ещё его без параметров запустить и он тебе хелп выдаст... а можно ещё и обратиться к Асмодеусу за комм. техподдержкой
Любой тупик - это тщательно замаскированный выход.

~AsmodeuS~
Site Admin
Сообщения: 5707
Зарегистрирован: Пт янв 28, 2005 3:11 pm
Контактная информация:

Re: Классы траффика

Сообщение ~AsmodeuS~ » Пт янв 08, 2010 12:04 pm

в конце добавить команду debug

smilethebest
Сообщения: 42
Зарегистрирован: Пн сен 21, 2009 8:09 am

Re: Классы траффика

Сообщение smilethebest » Вс янв 10, 2010 5:57 am

чето я не понял... вобщем в /etc/ppp/ip-up нет никаких признаков linkupdown скрипта...

/usr/abills/libexec/linkupdown mikrotik up eth0 smile 192.168.0.46 NAS_HOST=192.168.15.11 NAS_ADMIN=admin_ssh PROTO=pptp
правила в микротике появляются... в ip firewall mangle метятся коннекты. адрес листы на микротике тоже появляюца.

ОС линукс. так и не понял как запустить его в дэбаге. может логи есть какие? я ламер :)
может надо ipn прописывать в config.pl? или он там не нужен в данном случае?

да и кстате в /var/log/shaper появились записи комманд ssh для микротика. собственно как мне показалось они отсюда и брались чтобы в микротик залится. :)
/usr/abills/libexec/linkupdown mikrotik up eth0 smile 192.168.0.46 NAS_HOST=192.168.15.11 NAS_ADMIN=admin_ssh debug

Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
Count: 35 Remain Time: 2980157
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
Count: 36 Remain Time: 3066557
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
Count: 37 Remain Time: 3152957
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
Count: 38 Remain Time: 3239357
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
Count: 39 Remain Time: 3325757
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
Count: 40 Remain Time: 3412157
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
Count: 41 Remain Time: 3498557
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
Count: 42 Remain Time: 3584957
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
Count: 43 Remain Time: 3671357
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
Count: 44 Remain Time: 3757757
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
Count: 45 Remain Time: 3844157
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
Count: 46 Remain Time: 3930557
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
Count: 47 Remain Time: 4016957
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
Count: 48 Remain Time: 4103357
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
Count: 49 Remain Time: 4189757
Day: 0 Session_start: 0 => Int Begin: 0 End: 86400 Int ID: 12
<<!=
TT, 12
TIME_PRICE, 0
FIRST_INTERVAL, 12
Expresion:================================

END: =====================================
/ip firewall mangle add chain=forward out-interface=<pptp-smile> action=mark-packet new-packet-mark=TT_1_0_smile_mark_in comment=TT_1_0_smile_mark_in passthrough=yes
/ip firewall mangle add chain=forward in-interface=<pptp-smile> action=mark-packet new-packet-mark=TT_1_0_smile_mark_out comment=TT_1_0_smile_mark_out passthrough=yes
/queue tree add name=TT_1_0_smile_mark_in parent=<pptp-smile> packet-mark=TT_1_0_smile_mark_in limit-at=1048576 max-limit=1048576 queue=default-small priority=8 burst-limit=0
/queue tree add name=TT_1_0_smile_mark_out parent=global-out packet-mark=TT_1_0_smile_mark_out limit-at=1048576 max-limit=1048576 queue=default-small priority=8 burst-limit=0
/ip firewall address-list add list=TT_1_1_smile address=212.19.128.1/32
/ip firewall address-list add list=TT_1_1_smile address=212.19.128.2/31
/ip firewall address-list add list=TT_1_1_smile address=212.19.128.4/30
/ip firewall address-list add list=TT_1_1_smile address=212.19.128.8/29
/ip firewall address-list add list=TT_1_1_smile address=212.19.128.16/28
/ip firewall address-list add list=TT_1_1_smile address=212.19.128.32/27
/ip firewall address-list add list=TT_1_1_smile address=212.19.128.64/26
/ip firewall address-list add list=TT_1_1_smile address=92.47.255.248/30
/ip firewall address-list add list=TT_1_1_smile address=92.47.255.252/31
/ip firewall address-list add list=TT_1_1_smile address=92.47.255.254/32
/ip firewall address-list add list=TT_1_1_smile address=95.56.0.0/14
/ip firewall mangle add chain=forward out-interface=<pptp-smile> src-address-list=TT_1_1_smile action=mark-packet new-packet-mark=TT_1_1_smile_mark_in comment=TT_1_1_smile_mark_in passthrough=yes
/ip firewall mangle add chain=forward in-interface=<pptp-smile> dst-address-list=TT_1_1_smile action=mark-packet new-packet-mark=TT_1_1_smile_mark_out comment=TT_1_1_smile_mark_out passthrough=yes
/queue tree add name=TT_1_1_smile_mark_in parent=<pptp-smile> packet-mark=TT_1_1_smile_mark_in limit-at=0 max-limit=0 queue=default-small priority=8 burst-limit=0
/queue tree add name=TT_1_1_smile_mark_out parent=global-out packet-mark=TT_1_1_smile_mark_out limit-at=0 max-limit=0 queue=default-small priority=8 burst-limit=0
/ip firewall address-list add list=TT_1_2_smile address=10.0.0.0/24
/ip firewall address-list add list=TT_1_2_smile address=192.168.0.0/16
/ip firewall mangle add chain=forward out-interface=<pptp-smile> src-address-list=TT_1_2_smile action=mark-packet new-packet-mark=TT_1_2_smile_mark_in comment=TT_1_2_smile_mark_in passthrough=yes
/ip firewall mangle add chain=forward in-interface=<pptp-smile> dst-address-list=TT_1_2_smile action=mark-packet new-packet-mark=TT_1_2_smile_mark_out comment=TT_1_2_smile_mark_out passthrough=yes
/queue tree add name=TT_1_2_smile_mark_in parent=<pptp-smile> packet-mark=TT_1_2_smile_mark_in limit-at=0 max-limit=0 queue=default-small priority=8 burst-limit=0
/queue tree add name=TT_1_2_smile_mark_out parent=global-out packet-mark=TT_1_2_smile_mark_out limit-at=0 max-limit=0 queue=default-small priority=8 burst-limit=0
failure: already have such name
failure: already have such name
failure: already have such name
failure: already have such name
failure: already have such name
failure: already have such name


где косяк помогите разобраться... :)

smilethebest
Сообщения: 42
Зарегистрирован: Пн сен 21, 2009 8:09 am

Re: Классы траффика

Сообщение smilethebest » Пн янв 11, 2010 10:23 am

блин удалите ктонить верхнее сообщение моё :) нагромоздил ппц! :)
всё заработало с таким вот mikrotik_mshaper.sh:

DEBUG=1;
ACT_STATUS_TYPE=$1;
NAS_IP_ADDRESS=$2;
NAS_PORT=$3;
NAS_TYPE=$4;
USER_NAME=$5;
FRAMED_IP_ADDRESS=$6;

if [ w${ACT_STATUS_TYPE} = w1 ] ; then
if [ w${USER_NAME} = w$5 ] ; then
/usr/abills/libexec/linkupdown mikrotik up INTERFACE ${USER_NAME} ${FRAMED_IP_ADDRESS} NAS_HOST=${NAS_IP_ADDRESS} NAS_ADMIN=admin_ssh PROTO=pptp debug
echo "===> Started ${USER_NAME} session [NAS: ${NAS_IP_ADDRESS}]" >> /var/log/shaper
fi;

else if [ w${ACT_STATUS_TYPE} = w2 ] ; then
if [ w${USER_NAME} = w$5 ] ; then
/usr/abills/libexec/linkupdown mikrotik down INTERFACE ${USER_NAME} ${FRAMED_IP_ADDRESS} NAS_HOST=${NAS_IP_ADDRESS} NAS_ADMIN=admin_ssh PROTO=pptp debug
echo "===> Stopped ${USER_NAME} session" >> /var/log/shaper
fi;
else
echo "Not enough arguments";
fi;
fi;

но работает почему то только в определённом порядке задания сетей. и подсчёт трафика идёт только сети под номером 0:global, extended сети не считаются :( .
тоесть:
2 100.00000 0.00000 0 2048 2048 KazNet Изменить Удалить
1 1000.00000 0.00000 0 1024 1024 Global Изменить Удалить
так не считается но шэйпится нормально.
2 100.00000 0.00000 0 2048 2048 KazNet Изменить Удалить
1 1000.00000 0.00000 0 1024 1024 Global Изменить Удалить
0 50.00000 0.00000 0 512 512
а так будет резать весь трафик до 512 не зависимо от того какая сеть указана в 0-й сети. и весь трафик считает по 50 у.е. за мегабайт.
что скажете? можно узнать подробную информацию по сетям? в каком порядке их заводить, тарифы итд? читал документацию по модулю DV но скудновато и в общих чертах по сетям...

smilethebest
Сообщения: 42
Зарегистрирован: Пн сен 21, 2009 8:09 am

Re: Классы траффика

Сообщение smilethebest » Чт июн 10, 2010 5:31 am

короче так и не работает шэйпер по классам трафика...
вопросы:
1) есть стабильно работающий mikrotik_mshaper.sh?
2) после редактирования скриптов перезагрузать систему не надо? (linkipdown, mikrotik_mshaper.sh, итд)
3) какая разница между 0:Global, 1:Extended 2:Extended?
4) почему не прописываются правила по подсетям на микротике?

~AsmodeuS~
Site Admin
Сообщения: 5707
Зарегистрирован: Пт янв 28, 2005 3:11 pm
Контактная информация:

Re: Классы траффика

Сообщение ~AsmodeuS~ » Пт июн 11, 2010 7:56 pm

smilethebest писал(а):короче так и не работает шэйпер по классам трафика...
вопросы:
1) есть стабильно работающий mikrotik_mshaper.sh?
думаю в вашей версии чтото изменилось нужно смореть в конкретном случае что не так
smilethebest писал(а): 2) после редактирования скриптов перезагрузать систему не надо? (linkipdown, mikrotik_mshaper.sh, итд)
не надо
smilethebest писал(а): 3) какая разница между 0:Global, 1:Extended 2:Extended?
так это и есть разные классы трафика

smilethebest писал(а): 4) почему не прописываются правила по подсетям на микротике?
[/quote]

потомучито чтото не так делаете

adigo
Сообщения: 1
Зарегистрирован: Ср сен 01, 2010 10:31 am

Re: Классы траффика

Сообщение adigo » Пт окт 08, 2010 10:49 am

1.) народ, у кого нормально заработала связка микротик+абиллс ?
2.) при каких условиях идет нарезка трафика через mikrotik_mshaper.sh ?? а то сейчас он у меня нарезает только через передачу параметров радиуса.. хотя класы трафика выставлены.. IPN нада настраивать както ??
3.) каким скриптом проверить можно как работает linkdown+mikrotik_mshaper.sh (без непосредственного запуска linkdown с консоли.... ) ?
тоесть сделать емуляцию по типу radtest..

~AsmodeuS~
Site Admin
Сообщения: 5707
Зарегистрирован: Пт янв 28, 2005 3:11 pm
Контактная информация:

Re: Классы траффика

Сообщение ~AsmodeuS~ » Пн окт 25, 2010 12:06 pm

сморив внутрь скрипта там есть какая команда выполняется

Ответить